Home > Gateways > Cisco VG202 MGCP Template

Cisco VG202 MGCP Template

Hi All

Below is a configuration template that can be used to configure a Cisco VG202 Gateway using MGCP.

Of course with a few small changes you can also apply this to a VG204 or VG224 device

!
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XXXX
!
logging message-counter syslog
enable secret XXXX
enable password XXXX
!
aaa new-model
!
aaa authentication login VTY-LOGIN local
aaa authentication login CON-LOGIN local
!
voice service voip
fax protocol pass-through g711ulaw
modem passthrough nse codec g711ulaw
!
username XXXX privilege 15 secret XXXX
!
interface FastEthernet0/0
ip address X.X.X.X 255.255.255.0
duplex auto
speed auto
no shut
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 X.X.X.X
!
no ip http server
!
voice-port 0/0
cptone AU
!
voice-port 0/1
cptone AU
!
ccm-manager redundant-host X.X.X.X
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server X.X.X.X
ccm-manager config
!
mgcp
mgcp call-agent X.X.X.X 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface FastEthernet0/0
mgcp bind media source-interface FastEthernet0/0
!
mgcp profile default
!
dial-peer voice 900 pots
service mgcpapp
port 0/0
!
dial-peer voice 901 pots
service mgcpapp
port 0/1
!
line con 0
login authentication CON-LOGIN
no modem enable
line aux 0
line vty 0 4
privilege level 15
login authentication VTY-LOGIN
!
exception data-corruption buffer truncate
end

Enjoy……

The Voice Man

Advertisements
Categories: Gateways Tags: , , ,
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: