Archive

Archive for the ‘UCCX’ Category

CAD Agents Not Displaying In CSD Software

May 10, 2012 2 comments

Hi All

Had a few comments and concerns recently around the Cisco Supervisor Desktops (CSD) not being able to see all of the agents within the CSD software. Although the agents are part of the correct team they are not showing up.

Found the following information on how this issue can be resolved

Problem

CAD agents are not displayed on CSD

The agents that show up in CSD depends on the software communication. CAD software communicates to CSD about its state through UCCX. If communication breaks anywhere in this communication path, complete these steps in order to resolve the issue:
Note: This can occur because the sync is broken as the CSD shows no service after you choose the team.

Solution

1. Stop the Node Manager.
2. Restart the CTI manager in all the Cisco CallManager in the cluster.
3. Start the Node manager on the Master UCCX and wait until it appears.
4. Start the Node manager in the Secondary UCCX.

The Voice Man…

Categories: UCCX Tags: , ,

Reporting on Cisco Unified Communications Software

October 24, 2011 Leave a comment

Hi All

So you have implemented a new Cisco Unified Communications environment and would like to get some detailed reporting about the installation, configuration and system performance. Some of these applications have built in basic reporting options and of course you can use the RTMT (Real Time Monitoring Tool) to get more information out of the system, however there is another product which produces great detailed documents about the configuration and performance of the enviroment. The product Uplinx Report Tool for Cisco Unified Communications (www.uplinx.com)

This product can report on the following systems

– Cisco Unified Communication Manager

– CUCM Audit (change) report

– Cisco Unified Presence Server CUPS

– Cisco Unity Connection CUC

– Cisco Emergency Responder CER

– Unified Contact Center Express UCCX 8

– Microsoft Exchange 2007/2010 UM role

– Phone Inventory Audit (Change) report

– Phone Inventory report including Serial number, model, MAC, MWI, status, location, switch neighbour details.

For more information check out the datasheet at the following link

http://www.uplinx.com/RT/ReportTool_Datasheet.pdf

Enjoy…..

The Voice Man

Need a WallBoard for your UCCX Deployment

October 20, 2011 Leave a comment

Hi All

So you have just deployed a new UCCX contact centre environment and the client is now asking for a WallBoard to display some statistics for the environment. You show them the Supervisor software with the built in graphs and reports however it just doesn’t cut it.

A great piece of software that fully integrates with UCCX including UCCX ver 8.x is the QMC Agent Board IQ from Advatel (www.advatel.com.au). This piece of software can be loaded onto an agents individual workstation and be customised per queue but can also be template based depending on the type of contact centre.

Below is a link to this software, check it out

http://www.advatel.com.au/content/view/196/175/

Also here are some screenshots….

Enjoy….

The Voice Man

Configuring Voice QoS

October 19, 2011 Leave a comment

Hi All

Received some great documentation from a collegue surrounding Voice & Video QoS for edge routers to ensure Voice and Video traffic is prioritised when connecting over a WAN

This also gives you the abiilty to mark traffic based on it’s protocol so if you QoS is not setup properly it will still mark it and send it correctly accross the WAN.

 

WAN Interface QOS To Use Low Latency Queuing (LLQ)

class-map match-any voice-signaling

 match  dscp cs3

class-map match-any video-traffic

 match  dscp cs4

class-map match-any voice-traffic

 match  dscp ef

 

policy-map WAN-EDGE-OUT

 class voice-traffic   <————– Voice traffic

   priority 5120

 class voice-signaling <————– Voice Signaling

   bandwidth 768

 class video-traffic  <————– Video traffic

   bandwidth 2048

 class class-default <————– All other traffic will have the rest of the bandwidth

   fair-queue

 

interface GIG X/X

band 40000 <————– Sets Interface Bandwidth to 40Mbit

ip nbar protocol-discovery <————– Enables NBAR

service-policy input WAN-EDGE-OUT <————– Applies LLQ QOS policy

 

LAN Interface QoS To MARK Traffic.

ip access-list extended CISCO

 permit ip host “IP address” any

 

class-map match-any MARKING-video-traffic

 match access-group name CISCO

class-map match-any MARKING-voice-traffic

 match protocol rtp

class-map match-any MARKING-voice-signaling

 match protocol sip

 match protocol h323

 match protocol skinny

 

policy-map MARK-TRAFFIC

 class MARKING-voice-traffic <————– Mark voice traffic

   set dscp ef

 MARKING-voice-signaling <————– Mark voice signaling traffic

   set dscp cs3

 MARKING-video-traffic    <————– Mark video traffic

   set dscp cs4

 

Interface GIG X/X

ip nbar protocol-discovery  <————– Enables NBAR

Service-policy input MARK-TRAFFIC  <————– Applies marking QOS policy

 

Troubleshooting Commands

Use the following commands to display configured policies and class-maps:

Show policy-map [policy-map-name]

Show class-map [class-map-name]

 

Use the following command to display installed policies:

Show policy-map interface brief

 

Use the following command to display statistics of QOS policy applied in interface GIG X/X

Show policy-map interface GIG X/X

 

To display the statistics gathered by the Network-Based Application Recognition (NBAR) Protocol Discovery feature, use the show ip nbar protocol-discovery privileged EXEC command.

Show ip nbar protocol-discovery

Show ip nbar protocol-discovery [interface interface-spec] [stats {byte-count | bit-rate  | packet-count}][{protocol protocol-name | top-n number}]

 

Enjoy….

The Voice Man

Categories: CME, CUCM, Gateways, UCCX Tags: , , , ,

Does CAD and CSD work on Windows 7

October 18, 2011 Leave a comment

Hi All

Had a few questions lately surrounding support for the Cisco Agent Desktop and Cisco Supervisor Desktop running on a Windows 7 Workstation connecting through to a back-end UCCX 8.x environment.

Below is a link to the UCCX compatibility guide

http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/crs/express_compatibility/matrix/crscomtx.pdf

Below is a screenshot example showing that for UCCX 8.5.1 Windows 7 is supported along with some other useful information about the UCCX compatibility.

 

 

Enjoy…

The Voice Man

UCCX – Configuring Agent/Supervisor Recording & Monitoring within a Citrix Environment

October 18, 2011 Leave a comment

Hi All

Below is some  information I have documented to assist with the implementation of RSPAN and or VSPAN to allow for the Contact Centre agents to Record Calls within a Citrix user session. Currently Cisco Desktop Monitoring which is the default recording based configuration for UCCX is not a supported recording platform within a Citrix environment therefore the use of a server based monitoring platform is required.

A number of items will need to be configured to ensure that the server based monitoring option will work within the environment.

SPAN (Switched Port Analyzer) and RSPAN (Remote SPAN) analyze traffic passing through ports or VLAN’s to another port on the switch which either sends this information to a local destination port or through to a destination VLAN using RSPAN.

If the client has their agents connecting to a Cisco 3560 access switch and the UCCX server connecting to a core switch RSPAN will have to be utilized as the traffic will have to move across multiple switches.

Below is a diagram which illustrates the RSPAN process and how it will work within the network environment.

Currently there are two ways to configure RSPAN, one is by individually assigning each port to a RSPAN session, the other is to create a VLAN with Remote SPAN enabled and assign each of the ports configured for the UCCX agents to this VLAN. This then enables the whole VLAN to be monitored and therefore all traffic within this VLAN will be sent to the UCCX servers.

If the client has two UCCX servers for HA (High Availability) two monitor sessions will need to be configured to ensure that this feature is running for both the Primary and Secondary UCCX servers.

When configuring the network to support RSPAN there are three main ports to be configured, the source port, destination port and a reflector port. Each of these is described below

Source Port

A source port (also called a monitored port) is a switched or routed port that you monitor for network traffic analysis. In a single local SPAN session or RSPAN source session, you can monitor source port traffic such as received (Rx), transmitted (Tx), or bidirectional (both); however, on a VLAN, you can monitor only received traffic. The switch supports any number of source ports (up to the maximum number of available ports on the switch) and any number of source ingress VLANs (up to the maximum number of VLANs supported).

A source port has these characteristics:

•It can be any port type (for example, EtherChannel, Fast Ethernet, Gigabit Ethernet, and so forth).

•It can be monitored in multiple SPAN sessions.

•It cannot be a destination port.

•Each source port can be configured with a direction (ingress, egress, or both) to monitor. For    EtherChannel sources, the monitored direction would apply to all the physical ports in the group.

•Source ports can be in the same or different VLANs.

•For VLAN SPAN sources, all active ports in the source VLAN are included as source ports.

You can configure a trunk port as a source port. By default, all VLANs active on the trunk are monitored. You can limit SPAN traffic monitoring on trunk source ports to specific VLANs by using VLAN filtering. Only switched traffic in the selected VLANs is sent to the destination port. This feature affects only traffic forwarded to the destination SPAN port and does not affect the switching of normal traffic. This feature is not allowed in sessions with VLAN sources.

Destination Ports

Each local SPAN session or RSPAN destination session must have a destination port (also called a monitoring port) that receives a copy of traffic from the source ports and VLANs.

The destination port has these characteristics:

•It must reside on the same switch as the source port (for a local SPAN session).

•It can be any Ethernet physical port.

•It can participate in only one SPAN session at a time (a destination port in one SPAN session cannot be a destination port for a second SPAN session).

•It cannot be a source port or a reflector port.

•It cannot be an EtherChannel group or a VLAN.

•It can be a physical port that is assigned to an EtherChannel group, even if the EtherChannel group has been specified as a SPAN source. The port is removed from the group while it is configured as a SPAN destination port.

•The port does not transmit any traffic except that required for the SPAN session.

•If ingress traffic forwarding is enabled for a network security device, the destination port forwards traffic at Layer 2.

•It does not participate in spanning tree while the SPAN session is active.

•When it is a destination port, it does not participate in any of the Layer 2 protocols (STP, VTP, CDP, DTP, PagP, or LACP).

•A destination port that belongs to a source VLAN of any SPAN session is excluded from the source list and is not monitored.

•No address learning occurs on the destination port.

Reflector Port

The reflector port is the mechanism that copies packets onto an RSPAN VLAN. The reflector port forwards only the traffic from the RSPAN source session with which it is affiliated. Any device connected to a port set as a reflector port loses connectivity until the RSPAN source session is disabled.

The reflector port has these characteristics:

• It is a port set to loopback.

• It cannot be an EtherChannel group, it does not trunk, and it cannot do protocol filtering.

• It can be a physical port that is assigned to an EtherChannel group, even if the EtherChannel group is specified as a SPAN source. The port is removed from the group while it is configured as a reflector port.

• A port used as a reflector port cannot be a SPAN source or destination port, nor can a port be a reflector port for more than one session at a time.

• It is invisible to all VLANs.

• The native VLAN for looped-back traffic on a reflector port is the RSPAN VLAN.

• The reflector port loops back untagged traffic to the switch. The traffic is then placed on the RSPAN VLAN and flooded to any trunk ports that carry the RSPAN VLAN.

• Spanning tree is automatically disabled on a reflector port.

If the bandwidth of the reflector port is not sufficient for the traffic volume from the corresponding source ports and VLANs, the excess packets are dropped. A 10/100 port reflects at 100 Mbps. A Gigabit port reflects at 1 Gbps.

 

VSPAN – VLAN-based SPAN

The following configuration example provides a guide as to how to configure VSPAN for the Network.

Create a UCCX Recording VLAN

The following is required to create a VLAN for the UCCX agent on each of the Cisco 3560 switches to place them into a separate VLAN which is then configured for VSPAN

If VTP is enabled within the network then these VLANS can be added and then propagated throughout the network

Switch(config)# vlan (UCCX Recording VLAN)
Switch(config)# remote-span

Assign UCCX Agent Switchports to UCCX Agent VLAN

Switch(config)# interface fastethernet 0/x
Switch(config)# switchport voice vlan (UCCX Recording VLAN)

Configuring UCCX Agent VLAN for Monitoring on Primary UCCX Server

Switch(config)# monitor session 1 source vlan (UCCX Recording VLAN) both
Switch(config)# monitor session 1 destination remote vlan (UCCX 
Recording VLAN) reflector-port fastethernet0/1
Switch(config)# end

Configuring UCCX Agent VLAN for Monitoring on Secondary UCCX Server

Switch(config)# monitor session 2 source vlan (UCCX Recording VLAN)both
Switch(config)# monitor session 2 destination remote vlan (UCCX 
Recording VLAN)reflector-port fastethernet0/2
Switch(config)# end

Configuring UCCX Server

To ensure the UCCX servers are ready to accept the analyzed traffic from the monitored sessions the Primary and Secondary UCCX servers will need to be configured as per the following.

Please note the secondary NIC on each of the UCCX server will need to be configured and assigned to the UCCX Recording VLAN

Primary UCCX Server

Switch(config)# monitor session 1 source remote vlan (UCCX 
Recording VLAN)
Switch(config)# monitor session 1 destination interface 
fastEthernet0/x (Secondary UCCX NIC)
Switch(config)# end

Secondary UCCX Server

Switch(config)# monitor session 2 source remote vlan (UCCX 
Recording VLAN)
Switch(config)# monitor session 2 destination interface 
fastEthernet0/x (Secondary UCCX NIC)
Switch(config)# end

If the client decides not to implement VSPAN based monitoring and would like to implement individual based port monitoring via RSPAN then the following is an example configuration on how to implement this.

RSPAN – Remote SPAN

The following is required to allow for each of the agents ports on the switches to be monitored and then sent back to a RSPAN VLAN.

Configuring UCCX Agent VLAN for Monitoring on Primary UCCX Server

Switch(config)# monitor session 1 source interface fastEthernet0/1 both
Switch(config)# monitor session 1 source interface fastEthernet0/2 both
Switch(config)# monitor session 1 source interface fastEthernet0/3 both
Switch(config)# monitor session 1 destination remote vlan (UCCX 
Recording VLAN) reflector-port fastEthernet0/1
Switch(config)# end

Configuring UCCX Agent VLAN for Monitoring on Secondary UCCX Serve

Switch(config)# monitor session 2 source interface fastEthernet0/1 both
Switch(config)# monitor session 2 source interface fastEthernet0/2 both
Switch(config)# monitor session 2 source interface fastEthernet0/3 both
Switch(config)# monitor session 2 destination remote vlan (UCCX 
Recording VLAN) reflector-port fastEthernet0/2
Switch(config)# end

Configuring UCCX Server

To ensure the UCCX servers are ready to accept the analyzed traffic from the monitored sessions the Primary and Secondary UCCX servers will need to be configured as per the following.

Please note the secondary NIC on each of the UCCX server will need to be configured and assigned to the UCCX Recording VLAN

Primary UCCX Server

Switch(config)# monitor session 1 source remote vlan (UCCX 
Recording VLAN)
Switch(config)# monitor session 1 destination interface 
fastEthernet0/x(UCCX Recording VLAN)
Switch(config)# end

Secondary UCCX Server

Switch(config)# monitor session 1 source remote vlan 
(UCCX Recording VLAN)
Switch(config)# monitor session 1 destination interface fastEthernet0/x 
(UCCX Recording VLAN)
Switch(config)# end

Troubleshooting Commands to Assist with Implementation

sh vlan brief (Ensures VLANs are created and the correct agent ports are assigned)

show monitor session [session number] (Verifies monitor session configuration)

Enjoy…..

The Voice Man

Configuring QoS for Remote UCCX Agents and Supervisors

October 17, 2011 Leave a comment

Hi Everyone

Below is an example of some basic configuration that allows the Cisco Unified Contact Centre Express destop applications to be setup with priority when they are located accross a WAN environment and there are bandwidth restrictions in place. Cisco Agent and Supervisor desktops use the following ports to communicate back to the UCCX servers

tcp 42027
tcp 1099
udp 1099
tcp 59000
tcp 59020
tcp 59021

If you have ever experienced problems with agents disappearing from the Supervisor desktop software then it is more than likely a problem with communication between the agents, supervisors and UCCX server, and if they are located outside the “head office” or location of the UCCX servers then the below may assist with this issue.

The below also ensures this traffic is prioritised accross the WAN, and if your client is running a customer facing contact centre then this is a must have.

Apply the below configuration to your existing QoS polices

!
class-map match-all name UCCX-Clients-Voice
match access-group-all UCCX-Clients-Voice
!
policy-map (Policy-Map Name)
class UCCX-Clients-Voice
set ip precedence 3
bandwidth 500 (This can be changed based on the number of users per site and of course how much bandwidth there is at each site)
!
ip access-list extended UCCX-CLIENTS-VOICE
remark Allow Cisco Supervisor & Cisco Agent Desktop Software
permit tcp any any eq 42027
permit tcp any any eq 1099
permit udp any any eq 1099
permit tcp any any eq 59000
permit tcp any any eq 59020
permit tcp any any eq 59021

Ensure the above configuration is applied to the correct WAN interface as a service-policy output (Name)

If you want to lock this down even further to ensure only traffic on these ports to the UCCX servers themselves get prioritise you can change the above to the following by adding the IP Addresses of the UCCX servers on the access list

If UCCX redundancy is setup then the below will also be required to ensure during a failover that the agents get prioritised.

ip access-list extended UCCX-CLIENTS-VOICE
remark Allow Cisco Supervisor & Cisco Agent Desktop Software
permit tcp any host X.X.X.X (UCCX Server1) eq 42027
permit tcp any host X.X.X.X (UCCX Server2) eq 42027
permit tcp any host X.X.X.X (UCCX Server1) eq 1099
permit udp any host X.X.X.X (UCCX Server2) eq 1099
permit tcp any host X.X.X.X (UCCX Server1) eq 59000
permit tcp any host X.X.X.X (UCCX Server2) eq 59000
permit tcp any host X.X.X.X (UCCX Server1) eq 59020
permit tcp any host X.X.X.X (UCCX Server2) eq 59020
permit tcp any host X.X.X.X (UCCX Server1) eq 59021
permit tcp any host X.X.X.X (UCCX Server2) eq 59021

Categories: UCCX Tags: , , , , ,